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一．ColchisFM 介绍 

1. 关于 ColchisFM 

ColchisFM 是科吉思石油技术公司自主研发的油藏地球物理一体化正演软件，

其打通了岩石物理正演与地震正演，采用交互式岩石物理建模工作模式，实现了

从油藏地球物理参数到地震的一体化正演工作流程，内置叠前波动方程正演、叠

前时间偏移功能，能独立完成全部 1D、2D 叠后及叠前地震正演，可广泛应用于

储层地震特征分析、时移地震等研究，简单易学，自动化程度高，可作为地质研

究、地震解释、开发地震、储层反演等研究人员的油藏地球物理一体化正演工具，

也可用于院校地球物理教学研究及行业培训。 

2. ColchisFM 技术特色 

ColchisFM 历经多年研发与技术沉淀，是地学行业首款油藏地球物理一体化

正演软件，其采用了专利的智能地层识别技术，建模功能强大，正演方法完善；

软件上手容易，实时互动性强，用户体验好。其面向油田勘探开发实际需求，独

创性地将岩石物理正演与地震正演结合，可解决复杂岩性、多种孔隙等多种地质

条件的油藏模型建立及地震正演，适用于碎屑岩、碳酸盐、非常规油气藏等地震

特征研究，同时可以作为四维地震研究的一款利器，研究不同油藏参数下的地震

响应。可以作为盆地级的岩石物理参数库及模板库、地震反射特征库建设平台。 

3. ColchisFM 主要工作流程 

ColchisFM 正演主要包括叠后、叠前两个主要的常规工作流程： 

3.1 时间域叠后正演常规工作流程： 

1） 时间域工区建立：给定工区名称及工区路径，设置工区测线范围及正

演参数模式 
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2） 创建格架：绘制断层、层位后自动处理交切关系并识别地质体，或手

工绘制地质体 

3） 地质体属性赋值：赋弹性属性或油藏属性，可以用井进行插值 

4） 地质体网格化：执行油藏属性向地震网格映射并生成内部属性体 

5） 地震正演：进行时间域的叠后地震正演 

6） 查看正演结果：可调整地质体位置或子波联动观察叠后正演结果变化 

3.2 深度域叠前正演常规工作流程： 

1） 深度域工区建立：给定工区名称及工区路径，设置工区测线范围及正

演参数模式 

2） 创建格架：绘制断层、层位后自动处理交切关系并识别地质体，或可

手工绘制地质体 

3） 地质体属性赋值：赋弹性属性或油藏属性，也可以用井进行插值 

4） 地质体网格化：执行油藏属性向地震网格映射并生成内部属性体 

5） 时深转换（可选）：创建速度场，可转换到时间域，在时间域执行地质

体网格化，然后进行叠后正演 

6） 地震正演： 在深度域开展一键叠前正演、叠前时间偏移 

7） 查看正演结果：可将叠前正演的叠加剖面与叠后正演的剖面进行对比 

8） 道集处理：对道集进行切除及其它处理，重新进行叠加 

4. 软件安装 

4.1 安装系统环境 

 操作系统：64 位，Windows10 及以上，或 Linux RHEL7.0 及以上 

 内存：建议大于 8GB 

 硬盘：建议大于 20GB 

 CPU：建议 8 核以上 

 显示器：建议分辨率 1920*1080 以上，推荐系统文字缩放比例
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100%。 

4.2 ColchisFM 安装 

（1） 双击“ColchisFM.exe”程序进行安装，如果系统弹出如下提

示，请选择“是”。 

 

（2） 在安装界面上点击“Next”； 

 

（3） 选择安装路径（可采用缺省路径），如下图，然后点击

“Next”； 

 

（4） 当出现开始安装界面时，然后点击“Install”，并进入安装界

面； 
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（5） 正常安装结束后，会出现如下提示，点击“Finish”退出安装界

面； 

 

 

4.3 许可设置 

在安装完成后，从桌面双击“ColchisFM”启动，如果之前未配置过许可信息或

者许可已经过期，会出现以下提示： 

 

点击“OK”，然后进行 ColchisFM 的主界面，如下图： 
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点击菜单上的 “Help->License Install”，进入许可设置界面: 

 

可根据许可类型，选择是“Local File”本地文件或“Network Floating”浮动许

可。 

 

如果是浮动许可，可以在 Host 中填入对应的域名或 IP 地址，在 Port 中填

入端口号，可以点击“Check Connection”对网络连接进行检查，如果网络连接正

常，点击 Apply 或 OK 对设置进行应用。 

4.4 浮动许可服务器配置（可选） 

（1）将许可文件后缀修改为“.lic”，并拷贝到许可服务器安装的同级目录。 

在“License File”菜单下，点击“List All Valid License Files”可列出被识别的许可文件。 
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（2）在“Config Service”中设置可用端口号，如“10088”，点击“Apply”，然

后，点“Register Service”注册服务进程，然后“Start Service”启动服务进程。通

过“Query Service”查看服务是否注册成功。 

 

（3）在“License Usage”菜单中，点击 “Refresh License Usage Status”查看当

前许可服务的使用状态。 

 

5. 菜单及主要功能 

ColchisFM 界面如下图所示，主要由模型编辑与数据显示窗口构成，默认只

显示模型编辑主窗口。其中模型编辑主窗口包括其左侧的工具栏及上方的显示控

制栏。 
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主窗口工具栏包括编辑工具、井震数据管理、时深关系、窗口布局、赋值

网格化正演、道门信息等工具栏。 

ColchisFM 上方的主窗口包括工区、编辑、数据管理、模型属性、合成正

演、子波、岩石物理、数据处理、窗口、帮助等菜单。分别介绍如下： 

（1） 工区菜单：新建工区、打开工区、保存工区、复制工区、最近使用

工区、退出 

（2） 编辑菜单：回退、重做、放大、缩小、截图工具 

（3） 数据管理菜单：地震数据管理、SEGY 加载、建立时深关系、测井数

据管理、测井数据显示 

（4） 模型属性菜单：弹性属性模型选择、地质体属性赋值、执行地质体

属性网格化、网格化设置、属性计算器、输入外部图片、输出当前属性

到 SEGY、转换当前属性到内部地震数据格式 

（5） 地震正演菜单：叠后正演模式选择、执行叠后正演、声波快照显

示、波动方程正演、正演设置 

（6） 子波菜单：子波创建、子波编辑 

（7） 岩石物理菜单：岩石物理正演模块启动 

（8） 数据处理菜单：道集处理模块启动、叠后稀疏脉冲反演、反演结果

合并 

（9） 窗口菜单：增加新窗口、重置窗口、工具栏、其它窗口 



 

8 

 

（10） 帮助菜单：手册、线上支持、许可安装、关于 ColchisFM 

6. 关于手册及特定名词 

ColchisFM 油藏地球物理正演软件除了地震正演及其相关模块，还包括

ColchisRP 岩石物理正演、ColchisGC 道集处理两个子系统，关于岩石物理、道集

处理请参考对应帮助手册。 

地质体：指模型编辑中的单个对象 

赋值：指将地质体或地质体填上油藏参数或弹性参数 

网格化：指将地质体或地层的属性按地震网格进行映射，采样得到基于地震

网格的属性体 

地质体模板：指为了实现快速建立正演模型，保存矢量化特征的可重复利用

的单个对象 

地层格架：指在建立正演模型时，层位、断层交切关系已确定的组合体 

地层组合：指将由断层分隔的多个地层单元组合成一套地层，让它们具有同

一油藏参数、弹性参数特征 

 

二．工区建立 

（1）点击菜单”Project->New Project”新建工区： 

 

在对话框中，需要填入工区名称“Project Name”、工区路径“Project Path”；

选择工区参数类型 Parameterization；然后选择工区时深域 Domain，并填入工
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区横向（CDP）道数 Nums，横向（CDP）道间距 Interval；纵向深度填入网格点

数“Y Grid Nums”，默认纵向时间间隔 1ms，深度间隔 2m。上图中为新建工区默

认参数，对应工区为时间域，横向为 5000 米，纵向时窗为 1000ms。注：纵向

采样间隔默认对应常数速度 4000m/s，在时间域情况下，工区的最大深度由速

度场与最大时窗控制。 

（2）菜单“Project”中 Open Project 为打开工区，如果工区的次级目录中包

含工区，可能不会被识别，需要将工区拷贝至其它独立目录。 

（3）菜单“Project”中 Save Project 为保存工区。 

（4）菜单“Project”中 Copy Project 为拷贝工区，如下图，填入拷贝工区的

名称并设置路径，选择需要拷贝的项目，点击“Copy”进行工区拷贝。 

 

（4）菜单“Project”中“Recent Projects”为最近成功打开过的工区路径，可以

通过选择工区路径快速打开工区。 

 

三．格架模型建立 

1．利用层位、断层建立地层格架 

（1）层位编辑：左侧工具栏中第二按钮“ ”为层位绘制模式，点击它，就

可在模型编辑框口中绘制层位，左键开始绘制，右键结束；再点击按钮退出绘制

模式。选中模式下层位的颜色统一为 。 
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层位选中后，右键菜单可以选择“Edit”和非“Edit”状态。非“Edit”状态下，层位

只能进行移动。其他的编辑状态都在“Edit”下进行。快捷键四个箭头可以控制层

位的上下和左右移动，无需进行 Edit 状态的切换。 

Edit 状态下： 

① 移动点 

② 插入点 

③ 平滑 

④ 过滤 

⑤ 删除点 

右键菜单 “Object Setting...”为弹出对话框设置绘制层位的属性。“Horizon 

Name”是设置当前层位属于的地质分层和地质分层颜色，双击也可以弹出对话框。 

                       

（2）断层编辑：左侧工具栏中第三按钮“ ”为断层绘制模式，点击它，就

可在模型编辑框口中绘制断层，左键开始绘制，右键结束；再点击按钮退出绘制

模式。选中模式下断层的颜色统一为 。 
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断层选中后，右键菜单可以选择“Edit”和非“Edit”状态。非“Edit”状态下，断层

只能进行移动。其他的编辑状态都在“Edit”下进行。快捷键四个箭头可以控制断

层的上下和左右移动，无需进行 Edit 状态的切换。 

Edit 状态下： 

① 移动点 

② 插入点 

③ 平滑 

④ 过滤 

⑤ 删除点 

右键菜单 “Split Horizon”为把和断层相交的所有层位进行分割成两段。 

右键菜单 “Object Setting...”为弹出对话框设置绘制断层的属性。双击也可以

弹出对话框。 

 

（3）智能识别地层格架：左侧工具栏中第四个按钮“ ”为对绘制的层位、
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断层进行智能识别，形成不同的地层格架。若对形成的地层格架不满意可再次修

改，编辑断层、层位完成后，再次识别地层格架，形成新的地层格架。选中模式

下，激活格架地质体的边界颜色统一为 。 

 

 

格架地质体选中后，右键菜单可以选择“Object Setting...”弹出设置绘制地质

体的属性。 

其中，“Common”设置地质体的绘制属性，“Lithology”设置地质体的岩性属性。 

                          

（4）地层组合：有两种方式进行地层组合，一种是对自动识别出的地质体

（断块），在按住“Ctrl”状态下，用鼠标进行选择，在右键“Zone->Create”进行组合，

利用“Create->ungroup”进行解组合。 

另外一种是可左侧工具栏中第五个按钮“ ”为对自动识别出的地层格架进

行快速地层组合，分别用左键点击想要组合的地质体，点右键结束当前地层组合。

在全部地层组合完毕后，点击按钮退出组合地层状态。选中模式下，地层的边界
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颜色统一为 。 

组合过程中包含和两种特殊的状态： 

① 一个地质体如果已经被选中为当前的地层组合，当被再次选中时，将在

当前地层组合中取消此地质体。 

② 已经完成的地层，如果其中的一个地质体被再次选中，则在之前组合的

的地层中被删除。 

 

格架地质体选中后，右键菜单可以选择“Object Setting...”弹出设置绘制地质

体的属性。 

其中，“Common”设置地质体的绘制属性，“Lithology”设置地质体的岩性属性。 

  

2．自由编辑图形绘制地质体 

（1）地质体编辑 

左侧工具栏第七个按钮“ ”为自由编辑状态，可编辑任意形状的地质体，
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点击右键结束当前地质体编辑，点击按钮退出绘制状态。 

 

 

在“  ”状态下，点击地质体可对地质体进行自由编辑。地质体选中后，右

键菜单可以选择“Edit”和非“Edit”状态。非“Edit”状态下，地质体只能进行平移和

外框编辑调整地质体大小。其他的编辑状态都在“Edit”下进行。快捷键四个箭头

可以控制地质体的上下和左右移动，无需进行 Edit 状态的切换。 

Edit 状态下： 

① 移动点 

② 插入点 

③ 平滑 

④ 过滤 

⑤ 删除点 

⑥ 旋转 

地质体选中后，右键菜单可以选择“Object Setting...”弹出设置绘制地质体的

属性。 

其中“Common”设置地质体的绘制属性，“Lithology”设置地质体的岩性属性。 
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右键菜单“Save Template”将当前选中的地质体保存到模板库中。 

右键菜单“Copy”拷贝当前选中的地质体。 

右键菜单“Paste”粘贴当前拷贝地质体，包括属性。如果当前位置没有同类

对象，是全部粘贴。如果当前位置选中了同类对象，则只粘贴地质体的属性。 

右键菜单“Paste Property”粘贴当前拷贝地质体的属性。此功能只有在当前

位置是同类对象的情况下才有效。 

（2）地质体模板库 

点击左侧第八个按钮“ ”，可打开模板库工具栏，将其中的地质体拖入模

型编辑窗口，或者选中模板，在窗口直接框画地质体。再按需要对其进行大小调

整或重新编辑即可。 

 

地质体模板的操作和普通地质体一致。组合地质体模板可以通过右键

“Ungroup”将组合地质体分离成多个地质体。 

（3）绘制裂缝地质体 
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左侧工具栏第九个按钮“ ”为自由编辑状态，可编辑任意形状的裂缝地质

体，点右键结束当前裂缝地质体编辑。点击按钮退出绘制状态。裂缝地质体增加

了裂缝的属性特性和绘制效果，其他的操作和普通地质体一致。属性设置增加了

裂缝的设置，用户可以设置裂缝的角度，角度偏离，长度，长度偏差，分布密度，

宽度和转换速度，用来控制随机的生成裂缝的分布。 

           

                     

（4）地质体排列操作 

用户可使用“Ctrl”或者“Shift”+左键点击，或者在选择状态下利用框选，选择

多个地质体。右键菜单“Alignment”下的子菜单下任务，执行对地质体的排列操作。

地质体的排列操作包括了： 

① Top Alignment 

② Bottom Alignment 

③ Left  Alignment 

④ Right Alignment 

⑤ Same Height 
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⑥ Same Width 

⑦ Same Size 

⑧ Horizon Alignment 

⑨ Horizon Continual Alignment 

⑩ Vertical Alignment 

11 Vertical Continual Alignment 

       

               

 

（5）地质体组合 

用户可在选择了多个地质体后。右键菜单“Group”下的子菜单下任务，执

行对地质体的组合和解组合操作。地质体的组合操作包括了： 

① Group 

② UnGroup 
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组合地质体可以通过“Ungroup”解除组合。 

3. 以图片做背景绘制地层格架 

（1） 导入图片数据在“Edit”模式下，打开菜单“Property”下的“Import Current 

Property From Image...”，导入图片数据。也中以直接将图片文件拖入模型编辑窗

口。      
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（2）可以图片作为背景参考，绘制层位或者断层，并按照层位和断层构建

格架的流程形成地质体。 

               

 

四．油藏属性模型建立 

ColchisFM 目前支持多种途径对地层或地质体进行属性赋值，可以常数属性

填充、测井插值、岩石物理、外部数据体导入、图片数字化等方式。 

ColchisFM 目前支持五种弹性参数组合模式，包括纵波速度、纵波阻抗、纵波

速度-密度、纵波速度-横波速度-密度、泥质含量-孔隙度-含水饱和度（岩石物理）

等五种方式，其中后二种常作为叠前正演所需的属性组合。 

1．常数属性填充 

经过前述的操作，已初步得到了一个完整的地层、地质体剖面，现在为了

进行正演，需要对各个地层或地质体进行赋值，下图所示工区为默认的速度

“Vp”参数方式，点击上方主工具栏的“ ”，或者在“ ”状态下点击地层或地

质体，弹出选中对象的右键菜单，点击“Property Setting...”，打开属性对话框，

在对话框中填入其对应的属性值。  
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2．利用测井数据插值产生地质体属性 

ColchisFM 在深度域下可加入和显示井数据，对在用层位、断层形成格架地

质体基础上，可以利用测井数据插值进行属性体建立。 

（1）拖入井数据：打开菜单“Data”下的“Well Data Manager”，左键点击左侧列

表中的井名，并拖入模型编辑窗口。沿着井轨迹默认显示两条曲线、测井分层。

用户可以点击井轨迹拖动井改变井在二维剖面中的位置，在向上移动时，会出现

KB 数值。 

            

（2）左侧工具栏第六个按钮“ ”为井插值设置，如果已经成功建立地层格

架，并拖入测井数据后，属性插值“ ”会显示为激活状态。 

在窗口主菜单“Property->Interpolation Grid Setting”可设置网格化及插值参数， 

 “Resample Multiple”指建立格架时层位控制点重采样加密倍数 

 “Grid Num” 指设置格架地质体网格化的网格个数 

 “Smooth” 指格架地质体网格是否进行平滑，防止畸变网格的产生 
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 “Smooth Method” 指网格平滑方法，默认使用 Laplacian 平滑方法 

 “Smooth Factor” 指平滑参数，0-2 的变化范围，控制平滑的松紧度 

“Grid Type”下 

  “Smooth Method”指井插值后网格数据转化为地震网格的过程中使用的平

滑方法，包括“Shepard”和“Simple Kriging”两种方法 

 “Smooth Weight” 指平滑方法中的 y 方向松紧度控制 

 “smooth”和“map”表示井插值后属性网格数据转化为地震网格数据使用

的方法。“smooth”整体插值转换。“map”表示层内映射 

 

下图为插值后的属性分布及其网格密度 QC。 
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（3） 对于剥蚀、歼灭或者其他原因造成的网格异常情况，可以通过调整

地质体的范围进行网格重新剖分，再重新插值.  

       

如果需要重新剖分网格，右键点击需要调整的格架地质体，点击菜单

“Boundary Setting...”，在调整网格对话框中对地质体的四个顶点重新指定并产生

四条边，从而创建新的网格，重新进行插值。 

 

 删除点：在缺省状态下，点击删除点，当鼠标移动到地质体的连界顶点

时，点击可以删除角点。 



 

23 

 

 定义标记点：开始定义地质体的四个点。顺序是左上，右上，左下，右下。

对应颜色是绿，红，兰，黄。注：边界面上的顶点可以重复使用。 

 网格化：对定义的新的地质体按照原来的 x，y 网格数量进行网格化，形

成新的网格。 

 恢复原始状态：将地质体恢复到最初的状态。 

 重置：重新开始定义地质体的四个点。 
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3．通过岩石物理正演进行赋值 

ColchisFM 将岩石物理正演与地震正演有机结合，可以开展基于油藏参数的

地震正演，关于 ColchisRP 岩石物理，请详见其帮助手册。 

在工区建立后，可以从主窗口菜单“Property->Elastic Parameterization”进行

参数模式切换。当工区为“V1,V2,Porosity,Sw,T,P”参数模式时，通过模型编辑左侧

工具栏，点“ ”进入选择模式，选择地质体或地层，然后从菜单

“Property->Geobody Property”或在工具栏上点击“ ”， 打开属性赋值对话

框，将以岩石物理正演方式对地质体或地层进行赋值，如下图。 

 

在对话框中填入对应的体积模型参数， 

V1：指岩石物理 ColchisRP 中的第一种骨架参数，默认指石英砂 Sand 

V2：指第二种骨架参数，默认指干粘土 MixedClays 
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Total Porosity: 指总孔隙度 

Sw: 指含水饱和度 

其中，界面上“CurrentUI”指用当前 ColchisRP 界面上的岩石物理正演参数对

应的岩石物理模型，点击下方“Select>>>”可查看当前岩石物理模型。 

当改变上述这些体积模型参数时，ColchisFM 会通过岩石物理正演实时计算

其对应的弹性参数，可以点击“Basic Parameters”查看。 

 

其中 Vp 为正演的纵波速度，P-Impedance 为正演的纵波阻抗，S-Impedance

为正演的横波阻抗，Density 为正演的密度，Vs 为正演的横波速度，Vp/Vs 为正

演的纵横波速度比，Poisson 为正演的泊松比。 

 

4．油水界面赋值 

地质体可以通过以模拟油水界面的属性进行参数赋值，此赋值方式主要在

单个参数值模式下进行应用。右键地质体的“Object Setting...”，弹出对象属性对
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话框，选取“OWC”属性页，设置油水界面属性赋值。 

                 

“Contact”油水界面距离地质体顶部高度 

“Property”指某一种油藏属性，当油水界面生效时，对应下部的属性值 

“Ratio”为地质体中油水界面以上的属性对应下部的比值  

“Fix Value”油水界面上部是固定值或相对值 

“OWC”是否使用油水界面油藏属性 

5. 渐变属性赋值 

地质体可以通过设置梯度的方式进行属性赋值，此方式在地质体属性设置

范围内按照设置的梯度方向映射属性。右键地质体的“Object Setting...”，弹出对

象属性对话框，选取“Gradient”属性页，设置渐变属性赋值。 

               

“Orientation”设置梯度映射的八种默认方向，缺省的直线的位置范围是地质

体的矩形极限位置。用户可自行定义位置。方向按照规定方向。 

“Define”用户按照自行定义的方向和位置设置梯度映射。 
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“Property”选择定义的属性 

“Start Value”定义属性的开始值 

“End Value”定义属性的结束值 

“Gradient” 是否使用渐变属性 

4. 地层边界属性赋值 

边界属性赋值只适用于格架地质体或组合地层。地质体可以通过设置特殊

梯度属性进行油藏赋值。右键地质体的“Object Setting...”，弹出对象属性对话

框，选取“Special Gradient”属性页，设置特殊渐变属性赋值。 

            

“Distance”设置边界梯度的距离。 

“Coefficient”梯度属性的极值的比例。 

“Top”是否顶部边界梯度 

“Bottom”是否底部边界梯度 

“Left”是否左部边界梯度 

“Right”是否右部边界梯度 

“Adjacent”是否和相邻的地质体的边界梯度。相邻的地质体边界梯度的取值

来自两个相邻地质体的单值属性，形成渐变属性分布。 

“Apply All”应用到全部的地质体 

“Boundary”在没有自动获取边界的情况下，可以自行设定地质体的四个边

界。 

“Gradient”是否使用边界渐变油藏属性 
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“OWC”，“Gradient”，“Special Gradient”此三种属性赋值的设置在地质体的

应用中是互斥的，以最后设置的作为最终使用。 

5. 裂缝地质体属性赋值 

裂缝地质体的赋值方式可参考常规地质体的赋值，但裂缝体的属性只分布

于裂缝处，且所赋值会以累加的形式添加至属性数据体。 

下图中，为某裂缝地质体对应的属性 Vp 为“-300”，表示在执行网格化属性

时，会在最终的属性体中减少 300m/s。注：此数值理论上可以 ColchisRP 中通

过开展裂缝岩石物理正演得到。 

 

6.  从 SEGY 输入属性数据 

ColchisFM 除了通过建模生成地震网格的属性数据外，还能从外部输入 SEGY

数据或通过图片数字化生成属性数据。 
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从 SEGY 输入属性数据分为两步，即先将 SEGY 导入到工区内部格式数据（详

见 6.1 地震数据管理），然后将内部格式数据通过拖入加载进属性数据。  

在模型编辑窗口标题栏，点击“T”至时间域，从下拉菜单中切换到目标属性

体模式“Vp”，打开主窗口菜单“Data ->Seismic Data Manager”，在弹出窗口，用鼠

标左键点击数据体拖至模型编辑窗口，至此，数据已加载进当前属性。可在剖面

上移动鼠标查看当前位置数值，并根据需要，通过鼠标”右键菜单->Object Setting”，

设置当前属性的颜色方案及色标范围。 

 

7. 属性数据输出 SEGY 

在模型编辑窗口标题栏，切换至目标属性状态，如“Vp”，然后在主窗口主菜

单“Property->Export Current Property to SEGY”，在文件选择框中填入待输出的文

件名，可以将当前的属性导出到外部 SEGY 数据体。 

8. 利用图片数字化导入属性 

地震网格的属性可以直接通过数字化图片，按照设定的颜色和数值对应，

把图片直接映射到地震网格。切换到需要映射的地震属性状态下，直接拖入图

片或者在菜单“Property->Import Current Property From Image”下打开图片。弹出

设置颜色数字化对话框。 

 From Image 为颜色映射来自图片 

 From Colorbar 为颜色映射来自色棒 



 

30 

 

       

根据颜色和设定的属性范围，创建颜色映射后，可以创建地震网格属性 

           

9. 图层管理 

（1） 图层设置 

模型编辑所有的数据都有属于自己的图层，选中对象后，右键“Layer 

Order”可设置对象的图层顺序。 

              

① “Top”当前对象置顶 
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② “Up”当前对象上移一层 

③ “Down”当前对象下移一层 

④ “Bottom”当前对象置底 

（2）图层数据管理 

左侧工具栏第十个按钮“ ”为模型编辑所有的绘图对象管理。勾选

CheckBox 控制绘图对象是否显示，右键数据树节点可弹出菜单操作可操作

对象。 

                        

① “Rename”重新对数据命名 

② “Delete”删除对象及其子节点 

③ “Delete Data”删除选择的子节点 

④ “Layer Order”为图层顺序设置，可参考图层设置。 

上方的“ ”用来清空模型编辑窗口全部数据。 

 

五．地震正演 

1. 网格化操作 

在模型编辑窗口完成相应属性的测井插值或直接赋值后，可在时间域或深度
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域进行网格化操作，产生基于地震网格的属性体。 

从主窗口菜单”Property->Property Grid Process”，或者点击工具栏上 ，执

行网格化操作，会根据工区的参数类型完成对应属性基于地震网格的网格化。从

模型编辑标题栏上的下拉菜单可进行属性切换及查看，如下图。 

 

2. 叠后正演 

完成网格化操作生成 VP 等属性体后，在时间域可以开展叠后正演。ColchisFM

会根据工区弹性参数类型，采用不同的方案计算纵波阻抗。如果是采用的 VP，

会根据 Gardner 公式计算密度，然后计算纵波阻抗，并利用纵波阻抗计算反射系

数，再利用系统当前的全局默认子波进行正演生成合成记录。 

打开主窗口菜单”Synthetic->Post stack Synthetic Mode“选择叠后正演的模式，

点击”Synthetic->Seismic Synthetic”或工具栏上 执行正演。 

3. 正演结果查看 

叠后正演工作正常结束后，会生成正演数据体，在工具栏上点击“ ”增

加一个显示窗口，点击“ ”将重置各显示窗口尺寸。打开主菜单“Data->Seismic 

Data Manager”打开地震数据管理对话框，用鼠标左键点击“PostStk Seismic”中
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的数据体，拖入待显示的数据窗口，如下图。 

 

另外一种添加数据的方法是，在数据显示窗口，点右键“Display 

parameters”，在对话框中“Seismic property”中表格区域点击右键，从“Add 

seismic/layer”添加后缀为”.fms”的叠后数据体。（注：数据体需要在工区目录

下）。 

可以在右键“Display parameters”对话框中设置显示参数。 

 

对话框中上方可以查看该数据的相关信息，在下方“Seismic Property”中，

可设置相关显示参数，其中第一列“Seismic/Layer Name”为数据体内部名称，第

二列 Type 为数体类型，第三列为最小值，第四列为最大值，第五列 Gain（dB）

为数据的显示增益分贝数，第六列“Mode”可设置变密度 Density 或波形 Wiggle

显示方式，第七列“Colorbar”可设置色棒类型，第八列 Trace Skip 为显示横向显

示道间隔，此选项仅对波形显示生效。 

在对话框图层设置区域，点击右键可以进行删除图层、添加图层、向上/向
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上移动图层、重置图层最大最小值等操作。 

数据显示窗口右侧色棒可以浮动显示，点击其标题栏即可拖动显示，双击

色棒的颜色区域可以进行颜色编辑，双击数值区域可以设置图层的最大最小

值。 

4. 子波编辑 

ColchisFM 系统内置全局默认子波“Global_Default_Wavelete”，在叠后正演与

叠后反演时会采用默认子波。 

在主菜单“Wavelete->Wavelete Create”打开子波产生对话框，对话框中可以调

整子波各项参数，并在下方实时查看子波形态。 

当打开”Auto Apply”选项时，调整子波参数，会实时应用当前子波。 

 

在主菜单“Wavelete->Wavelete Edit”打开子波编辑对话框，可以对子波进行编

辑，鼠标左键可以选择控制点并移动修改子波，其中鼠标中键选择区域可进行放

大显示，鼠标右键菜单可以缩小显示。 
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在新产生或编辑默认子波后，再次执行叠后正演（详见 5.2）时会自动应

用最新子波。 

5. 添加噪音 

针对叠后正演，可以在反射系数上增加随机数，从而实现叠后正演添加噪音

的效果。从主窗口菜单“Synthetic->Synthetic Config”打开正演设置对话框，在

“Synthetic”中设置噪音系数。 

 

然后再次进行叠后正演，效果如下图。 
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6. 速度场建立及时深转换 

ColchisFM 主要分为叠后时间域与叠前深度域两个主要正演工作流程，内置

一套地质模型与地质网格，模型可以在时深域进行切换并编辑，在不同域进行网

格化，会生成不同域对应的网格属性。ColchisFM 可以以三种方式建立时深转换

速度场，即常数速度场、精细速度场（当前 Vp 属性）、外部速度场，在主窗口菜

单“Data->Create Time-Depth Relationship”可以进行设置，或点击主工具栏上 、

、 进行设置。 

（1） 常数速度场 

在工区建立时，如果时间间隔（Time Interval）设定为 1ms，深度间隔

（Depth Interval）设定为 2m，那么如果将常数速度场设置为 4000m/s 时，在

时间域与深度场进行切换时，可以保持构造形态不变且时窗长度保持对应。 

（2） 精细速度场 

在生产中使用时间域地震资料开展构造研究时，经常会碰到浅层含气、

异常地质体厚度变化或下盘厚度增厚对下覆地层构造造成一些假象，针对这

类问题，ColchisFM 可以在深域度或时间域利用当前的 Vp 属性体建立时深转

换速度场。 

（3） 外部速度场 

ColchisFM 有两种方式导入速度场，可以从外部文件导入区域速度或从

测井时间-深度曲线加载外部速度场。 

选择“ ”，然后选择深度域的速度文件，其中速度文件第一列为深度，

第二列为速度，如下图： 

 

在弹出的对话框中会显示当前速度场： 
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其中第一列为深度，第二列为速度，第三列为计算出来的双程时间。

点击“Apply”即可应用当前的速度场。 

（4） 速度体的查看 

在模型编辑窗口，点击下拉菜单中的“Vp_TD”，可以查看当前的时深转换

速度场。 

7. 叠前波动方程快照 

利用 ColchisFM 可以进行叠前正演，在开始叠前正演前，可以利用波场快照

的方式查看各反射界面的波场情况。 

打开主窗口菜单“Synthetic->Acoustic Wave Snapshot”，会出现“Modeling”的工

具栏，包括炮检点位置设置“Shot-Receiver Location”、快照启动“Snapshot Start”、 

快照停止“Snapshot Stop”。打开炮检点位置设置对话框，可以设置炮点位置 CDP 

of the shot、炮点与第一道的距离“Distance between shot and first receiver”、检波

点数“Number of receiver stations”、检波点间隔“Receiver location increment”，如

下图。 
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点“Apply”应用，在模型编辑栏上可以看到炮点与检波点的位置关系示意。 

在工具栏中点“ ”，可以启动快照，如下图，点击“ ”结束快照。 

 

8. 一键叠前波动方程正演 

ColchisFM 将叠前正演、抽道集、叠前时间偏移等工作流进行了内部整合，

用户可一键完成叠前正演工作。 

打开主窗口菜单“Synthetic->Wave Equation Modeling”,在工具栏上会出现

“ ”，点击可出现叠前正演设置对话框。“Geometry Design”为观测系统设置，

“Wave Equation Forward Modeling”为波动方程正演设置，“Prestack Migration”为

叠前时间偏移设置。 

在“Geometry Design”的“Source Setting”中： 

Number of shots：指要正演的炮数 

CDP of the first shot：指第一炮的炮点 CDP 位置 

CDPs increment between shots：指炮点间隔 
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Depth(m) of the shot：指炮点深度 

在“Geometry Design”的“Receiver Setting”中： 

Distance(in CDPs) between shot and first receiver：指炮点与第一个检波点间

的距离 

Number of receiver stations：指每一炮的检波点数 

Receiver location increment(in CDPs)：指检波点间隔 

 

 

在“Wave Equation Forward Modeling”中： 

Modeling method：指叠前正演的方法，可以选择声波“Acoustic Wave”和

弹性波动方程“Full Wave” 

The length of record(ms)：指正演炮集记录长度 

Source wavelet peak frequency(Hz)：指子波主频 

Wavelet declay(ms)：指子波延迟时间 

Highest frequency range(Hz)： 指记录的最高频率 

Gaussian blur radius：指高斯模糊半径 

Forward time step(ms)：指正演时间步的步长（注：不是输出炮集时间间

隔） 

Refined grid length(m)：指正演时重新网格化产生高精度的网格尺寸 

Regrid from origin model：指在原始模型基础上进行网格化，对于小尺寸

（低于道间隔，比如<25 米）地质体可以选择 

CPU threads：利用的 CPU 线程数 

Use GPU：是否利用 GPU 加速 
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在 Prestack Migration”中： 

Migration imaging maximum angle: 指偏移成像最大角度 

Minimum offset(m)：指偏移的最小偏移距 

Maximum offset(m)：指偏移的最大偏移距 

Increment offset(m)：指偏移距的偏移距间隔 

CPU Threads：利用的 CPU 线程数 

 

设置好各项参数后，点击 “Submit”可以提交作业，点 “Show log”可以查

看当前作业进程。 

当正演作业全部正常结束后，会生成经过叠前正演、叠前时间偏移后的道集

“PRESYN_CDP_Gather” 与 叠 加 数 据 “PRESYN_CDP_STK” ， 可 以 在

“Synthetic->Synthetic config”的“Output default”中自定义输出文件名。 
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9. 道集处理 

具体说明请详见道集处理模块中的帮助手册。 

在完成叠前时间偏移后，可对道集开展处理，常见地，可对道集进行切除和

叠加，以消除道集中远道畸变带来的分辨率下降的影响。 

从主窗口“Processing->Gather conditioning”打开道集处理模块，从左侧“Input”

模块中选择“Seismic”下后缀为“.fmg”的道集，右侧窗口即会显示此道集，拖动右

侧工具栏中的范围选择滑块，可以实时查看不同位置的道集。 

将左侧“Mute”勾选，在右侧上方工具栏选择“ ”顶部切除按钮，用左键选

择切除控制点，点右键结束，然后在“Process &Stack”可完成道集处理和叠加。 

 

正常完成后，会出现“Add seismic stack file successfully”提示。默认地，会将

叠加数据“PRESYN_CDP_STK” 进行更新。 

10. 地震反演 

ColchisFM 可以进行基于稀疏脉冲算法的叠后反演，在主窗口菜单中点击

“Processing->Inversion”，打开反演对话框。 

在 Input 中选择要反演的数据体名称，如“POSTSYN_STK”，在 Wavelet 选择

默认系统子波，Scale 可以设置子波的比例因子，如下图： 
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在“Sparse-spike Inversion”中, 

L1 Regularization: 为正则化参数 

Iterations: 为最大迭代次数 

 

在“Merge Filter”的“Low Frequency Trend”中，可以设置低频参数，有两种低

频选择方式，Constant 可以将常数作为低频，从 Data 中选择数据体作为低频来

源。“Merge Filter(Hz)”为合并频率参数，其中 Low filter 为低频,Low overlap 为低

频重叠参数,High filter 为高频,High overlap 为高频重叠参数。 

 



 

43 

 

 

“Output”中可以设置反演系数 Reflectivity、反演阻抗 P-Impedance、合并阻

抗 P-Impedance Trend Merged、带通阻抗 P-Impedance Bandpass 的默认输出文件

名。 

 

可以将 P-Impedance Trend Merged 反演结果添加到右侧窗口与原始的模

型进行对比分析。 

 

在一键完成叠后反演后，可以再次进行频率合并测试，点击主窗口菜单
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“Processing->Merge Filter”，打开频率合并对话框，在“Input”中可以选择带通阻

抗数据，其余选项可与反演中同样进行设置。 

 

11. 时深转换 

ColchisFM 可以对属性数据体，比如正演数据体进行时深转换，首先需要生

成时深转的速度场，目前支持三种方式建立速度场，在菜单“Data->Create Time-

Depth Relationship”中进行，默认为空，这时模型编辑界面上 T<->D 不能进行互

转。  

其中第一种“Constant Interval Velocity”为常数速度场，可以用来在保持构

造形态下进行时深转换，如果工区新建时间间隔设置为 1ms，深度间隔为 2m，

那么其对应的默认速度为 4000m/s，生成速度场后，可以通过在模型编辑窗口下

选择“Vp_TD”进行查看； 

第二种“From Current Vp Velocity”为精细速度场，为当前在模型编辑窗口

网格化后的速度场，在时间、深度域均可以自动生成速度场。 

第三种“From TD Table”为通过时深对建立速度场，其中又分为两类，第一

类为外部时深对，第二类为通过测井速度或时差曲线曲线计算得到，其中外部时

深对文件格式为下图，其中第 1 列为深度，第 2 列为速度。 
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在创建时深转换对应的速度场后，从菜单 “Processing->Time/Depth 

Conversion”中打开对话框。在话框中设置转换模式并选择对应的数据体，点击

“Process”进行转换。 

 

12. 数据处理 

ColchisFM 可以对叠后数据进行快速处理，包括滤波处理、相位旋转、自动

能量均衡（AGC）、时移处理、数据计算、道积分等。其中滤波包括带通滤波、高

通滤波、低通滤波功能；数据计算包括与常数的加、减、乘、除或与另一数据体

的加、减、乘计算。 

从“Processing->Process & Attributes”打开数据处理对话框，如下图： 
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在选项卡选择某一功能为当前选项，在“Out Suffix”中填入后缀，然后点击

“Start”进行数据处理。 

六、数据管理 

ColchisFM 作为正演软件，会通过正演产生一系列地震数据，也可以将外部

SEGY 数据导入作为模型属性。在利用测井进行曲线插值时，也需要将外部测井

数据导入，下面分别介绍地震与测井数据管理。 

1. 地震数据管理 

（1） 数据管理 

从主窗口菜单“Data->Seismic Data Manager”，打开地震数据管理窗口，如下

图。 

 

其中“PostStk Seismic”指的是叠后数据，“CDP Gathers”指的是道集数据，可
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以从表中查看数据的不同信息，第一列是动态编号，第二列是数据名，第三列

是数据维数，第四列是数据类型，第五列是时间-深度域信息。 

在列表中可点击右键，菜单“Detail Information”可以查看该数据的详细信

息，“Copy”可以对数据进行拷贝，“Rename”可以对数据进行改名，“Delete”可以

删除数据。 

（2） SEGY 数据加载 

从主窗口菜单“Data->Import Segy File”，打开数据加载对话框。根据数据设

置线、道号信息，点击“Create Link File”对文件开始扫描生成索引文件，然后点

击“Load Seismic to Database”，将数据加载到工区数据库。注：默认在 ColchisFM

软件 2D 版本中，只会对主测线（ILine）线号为 1 的数据进行显示。 

 

2. 测井数据管理 

（1）数据管理 

ColchisFM 集成了 ColchisRP 模块（可详见其帮助手册），其测井数据管理主

要依赖于 ColchisRP。从主窗口菜单“Data->Well Data Manager”，打开测井数据管
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理。 

 

左侧为井名，右侧窗口为该井曲线、分层、井头信息。 

（2）LAS 数据加载 

从菜单”File->Well import”可打开测井数据加载对话框，如下图。当加载 LAS

文件时，会在左侧显示该井的部分信息，包括文件名、文件类型、井名、采样

间隔、起始深度等信息。 

 

点击左侧窗口的数据条目，在右侧会动态显示该井全部曲线信息，可以修

改曲线对应的类型、单位信息。也可在测井数据区打开右键菜单，对曲线数据

进行计算、填充、拷贝、粘贴等编辑。 

 

七、正演示例 

为帮助用户快速了解 ColchisFM，下面介绍叠后正演与叠前正演的快速流程。 
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1．叠后正演 

新建工区：从“Project->New Project”打开新建工区对话框，输入工区名

“project2d”，并设置工区路径，其它参数保持默认，点击“OK”； 

 

绘制层位及断层：从模型编辑左边工具栏选择“ ”，用鼠标左键绘制四个

层位（如图），点右键结束绘制；选择“ ”，用鼠标左键绘制一条断层，点右

键结束绘制。 

 

创建地层格架：从模型编辑左边工具栏点击“ ”，即自动完成格架处

理，如下图。 
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地层组合：从模型编辑左边工具栏，点击“ ”进入地层组合模式，然后

用鼠标左键依次点击要组合的地层，点右键结束一套地层的组合。再次点击

“ ”或点击“ ”退出地层组合模式。 

 

绘制地质体：从模型编辑左边工具栏，点击“ ”进行地质体绘制模式，

鼠标左键绘制一个地质体，右键结束绘制。再次点击“ ” 或点击“ ”退

出地质体绘制模式。 

 

地质体属性赋值（填弹性参数）：从主窗口工具栏，点击“ ”打开地质

体属性赋值对话框，如下图。点击模型编辑左侧工具栏“ ”，进入选择模

式。依击点依各地质体或地层，并在右侧“Vp”处填入对应的速度值。注：各

地质体或地层默认的初始 Vp 为 2000m/s。 
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地震正演及结果查看：从主窗口工具栏，点击“ ”进行属性体的网格

化，再点击“ ”完成叠后正演。从主窗口工具栏，点击“ ”，或右键点

击模型编辑标题栏，从右键菜单选择“Add Panel Right”，添加一个数据显示窗

口。点击“ ”打开地震数据管理窗口，左键点击生成的叠后正演数据并拖入右

侧窗口，如下图。 

 

2．叠前正演 

叠前正演需要建立深度域的模型，可以参考叠后正演的流程建立深度域的模

型，差别在于新建工区时，选择“Depth”设置模型为深度域。 

ColchisFM 可以通过设置常速速度场，让模型在时、深两域保持构造形态进
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行互相转换（详见 5.11，时深转换）。 

下面介绍在完成叠后正演示例基础上，开展叠前正演。 

速度转换（可选）：在主窗口菜单上选择“ ”，在弹出的速度设置对话框

中，点“OK”，完成速度场建立，此时模型编辑窗口标题栏上的深度域“ ”

会被激活。 

 

点击“ ”即可切换到深度域； 

 

叠前正演：点击“ ”进行属性体的网格化，从主窗口菜单选择

“Synthetic->Wave Equation Modeling”，点击主窗口工具栏上的“ ”，打开叠

前正演设置对话框，在对话框中点击“Submit”开始叠前正演，可通过点击“Show 

log”打开作业信息查看。 
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在叠前正演完成后，从主窗口工具栏，点击“ ”，或右键点击模型编辑

标题栏，从右键菜单选择“Add Panel Right”，添加一个数据显示窗口。点击

“ ”打开地震数据管理窗口，左键点击生成的叠前正演叠加数据并拖入右侧窗

口，如下图。 
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由于默认全叠加包含了远道信息，可进行道集处理（详见 5.9 道集处理），

对全叠加结果进行更新，为了更方便的与原始模型对比，可以点击主窗口的

“ ”建立精细速度场，并点击模型编辑窗口标题栏上的“ ”，将模型切换到

时间域。 

 

 

八、其它说明 

1. 工区目录结构 

默认地，工区目录下由部分目录与内部文件组成，其中 WellDataBase 为

ColchisRP 测井工区目录，Seismic 为地震数据存放目录，RPLibrary 为岩石物理库
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存放目录，PreMigProcess 为叠前正演、叠前偏移等处理临时目录，Predefine 为

预定义文件存放目录，Geobody 为地质体模板存放目录，colchisfmedit 为工区模

型存放目录。 

2. 默认工区测线 

ColchisFM 2D 版本默认设置工区为一条主测线（ILINE，线号为 1），可以打开

窗口主菜单“Window->ToolBars->Tracegate”，然后从对应工具栏读取线道信息。 

3. 文件命名约定 

ColchisFM 对不同类型的数据进行了预定义，对于地震数据体，前缀“MODEL_”

代表模型数据，前缀“PRESYN_”代表叠前正演数据，前缀“POSTSYN_”代表叠后正

演数据，前缀“INVERSION_”代表反演数据；关键字“CDP”代表道集相关，关键字

“STK”代表叠加相关。 
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